OpenWRT - Home Access Point

USB Storage

opkg install kmod-usb-storage kmod-fs-ext4 e2fsprogs block-mount

Edit /etc/config/fstab.

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '1'

config swap
	option device '/dev/sda1'
	option enabled '1'

config mount
	option device '/dev/sda2'
	option enabled '1'
	option target '/mnt'
	option options 'sync,noatime,nodiratime,nouser_xattr,discard'

HUAWEI Mobile USB Dongle

opkg install kmod-usb-serial-option usb-modeswitch
usb-modeswitch -l
logread -e 'GSM modem'

DNS Crypt Proxy

opkg install dnscrypt-proxy luci-app-dnscrypt-proxy

Use soltysiak proxy server where

  • DNS Security Extensions are supported
  • Namecoin domains can be resolved
  • Provider supposedly doesn’t keep logs

Edit /etc/config/dnscrypt-proxy.

config global
	option procd_trigger 'wan'

config dnscrypt-proxy 'ns1'
	option address '127.0.0.1'
	option port '5353'
	option resolver 'soltysiak'

Add the proxy into config dnsmasq in /etc/config/dhcp.

	list server '127.0.0.1#5353'
	list server '/pool.ntp.org/8.8.8.8'

6in4 Tunnel

opkg install 6in4

Edit /etc/config/network (the metric is higher then default 1024 to prefer other gateways, e.g., the vpsFree IPv6 tunnel).

config interface 'wan6'
	option proto '6in4'
	option peeraddr '216.66.86.122'
	option ip6prefix '<your prefix>::/48'
	option tunnelid '<your tunnel id>'
	option username '<your user name>'
	option password '<your password>'
	option ip6addr '<your address>::2/64'
	option metric '2048'

OpenVPN

It requires OpenSSL which is also required by openssl-util for acme, so it does not make sense to use openvpn-mbedtls.

opkg install openvpn-openssl luci-app-openvpn

vpsFree IPv6 Tunnel

Save vpsFree IPv6 tunnel configuration file ipv6tun-*.conf to /etc/openvpn.

Edit /etc/config/network and /etc/config/firewall according to the instruction in the file above.

L2TP/IPsec

opkg install xl2tpd

VUT VPN Tunnel

Edit /etc/config/network.

config interface 'vutbr'
	option proto 'l2tp'
	option server 'vpn.vutbr.cz'
	option password '<your password>'
	option ipv6 'auto'
	option username '<your user name>'
	option defaultroute '0'
	option peerdns '0'

config route
	option interface 'vutbr'
	option target '147.229.0.0'
	option netmask '255.255.0.0'

Add the interface vutbr into option network in zone wan in /etc/config/firewal.

Let’s Encrypt (ACME)

opkg install luci-app-acme

 Share!

 
comments powered by Disqus